Welcome aboard Visitor...

Daily Screenshot

Server Costs Target

Target met!

Latest Topics

- Reminiscing »
- Holly Cow Its alive!! »
- Messenger Battle Chat by T-Roy! »
- Getting our Player Base back »
- Fully customizable ships? »
- First Person view is possible in DS! »
- What's with the new Metaverse? »
- Carrier default loadouts - ships w/interceptors only? »
- 01001000 01100101 01101100 01101100 01101111 »
- the mi type ships cheat »

Development Blog

- Roadmap »
- Hello strangers, it’s been a while... »
- State of DarkSpace Development »
- Potential planetary interdictor changes! »
- The Silent Cartographer »
- Cloaking update... »
- Tools for tips »
- Fleet levels and more! »
- Game Mechanics Question and Answer Thread »
- Under Construction »

Combat Kills

Combat kills in last 24 hours:
Kills chart

Upcoming Events

- Weekly DarkSpace
08/24/19 +4.6 Days
- International Talk like a Pirate Day!
09/19/19 +29.9 Days
- Towel Day
05/25/20 +278.9 Days




No anniversaries today.

Facebook & Twitter

Why not follow us on Twitter or Facebook for more information and fan updates?

Forum Index » » Developer Feedback » » cant connect after launching GCQL?
 Author cant connect after launching GCQL?
Chief Marshal
Galactic Navy

Joined: March 29, 2003
Posts: 4031
From: The Gideon Unit
Posted: 2013-12-16 20:10   
first up, simply restarting GCQL seems to fix the problem.

in the interest of gathering data on the cause of the problem (cause it looks pretty random),
if you notice that you're unable to connect to a game server after launching GCQL (be it 5 minutes or 50 minutes after), please check the browser tab and see if you're logged in to the website or not, and report the results here.
additionally, if you find you are not logged into the website, could you then log in to the website, then try again to connect to the game server?

  ICQ status

Joined: December 18, 2007
Posts: 218
Posted: 2013-12-17 04:38   
good you've taken on this problem. I did notice it but never seemed important enough to mention.

i did try manually logging in browser tab, but that doesnt help. If the client doesnt auto log me in darkspace website, I need to relog to be able to log into metaverse server. Never knew the website had an important role in launching the server btw:P
The greatest trick the devil ever pulled, was convincing the world he is a bot

Chief Marshal
Army Of Darkness

Joined: January 01, 2003
Posts: 60
Posted: 2013-12-17 06:20   
Same thing happens to me, seems to be only the first time I log in after starting up my computer. Not that it happens everytime, just it seems to happen most often then.

I just check the browser tab to see if logged in now before I try to connect to the game, if I'm not logged in on the web page it won't let me get into game (just says disconnected).

Easy fix though, just exit gcql and start it again.

Pand0rum (Dragoon)

Joined: May 06, 2007
Posts: 50
From: Arizona
Posted: 2013-12-19 19:09   
Same thing had happened to me. I noticed that every time that the game crashed, it said that I wasn't logged in, but I could see my name in the chat room. I wonder if this is a bug?
I play every faction <3

Fleet Admiral

Joined: June 06, 2003
Posts: 449
From: USA, WI
Posted: 2013-12-20 10:25   
Run GCQL.exe from desktop icon
-Windows vista popup - gcql requesting permission... ya ya
-does the update thing..
-auto log in of username and password-
Game window chat opens
Browser tab says Hello visitor.

At this point apparently the gcql did not log me into the server. On trying to join the MV, it updates, launches the client side server and fails to connect. Probably cause I am not logged in via the client so I get rejected.

I log into the web site via the browser tab, but still can not connect to the server. Probably because I manually logged into the 'web site', not the server which is what gcql is supposed to do, so I get rejected still.

Shut down gcql, and close it completely from the tray icon. Run gcql again, and this time it loges me in to both the web page and server, so it works fine.

Speculation; After I stop playing, time passes and I run gcql again, the initial contact with the server (or web site) fails. So to play I have to run gcql twice as the first log in attempt fails but the second succeeds. Have not waited a time span to see if true, or how long it takes for my log in to fail.

Things to try, disable auto log in - perhaps its logging me in to fast, or out of order, something.. and fails to log me in properly. But should prevent all attempts, probably not cause but can try.

Try enable 'run as admin', so it wont ask permission. But then should prevent all attempts so probably not. But can try.

Other things to try on our end?

Windows vista home, 64 bit, quad core.

edit- at this time gcql still logs me in fine on 1st try. So for me the time to cause the issue must be longer, or its fixed/ one time issue. (2230 hours central) Even restarted computer, works fine.

[ This Message was edited by: Drow on 2013-12-21 17:16 ]

1640 on dec 21, failed to log in.

Nindol tangi, dos zhal zah'har l' jiv'undus d'
natha szithrel Tagnik'zun elggor

  ICQ status
Orkan [OO-XII]
Fleet Admiral
The Myrmidon Legion

Joined: April 22, 2010
Posts: 201
From: A Point Perfectly Computed Yet Never Repeating
Posted: 2013-12-20 19:48   
Drow describes this issue well.

I launch GCQL (from icon)
enter password on initial login box.
Enter Chat, see player names in lobby.
In browser I am not logged in.

Whether or not I login to browser, the first time I launch(connect) hydra it loads up until 'Darkspace' text intro screen then always says 'connection lost - quit, retry'

quit returns me to GCQL, retry is fruitless.

If i choose to launch again without closing GCQL it always fails to connect


I quit
I close GCQL, (by now I just hit the 'x' to close program in the actual window)

I relaunch GCQL

I connect to Hydra server - this time all is sweet and goes smooth.

(if only it worked like this, like it used to before in 1.69, the first time round.)

It's not cool and many people, I would imagine, find this an irritable 'workaround'.

I do hope you manage to get it sorted.


(running on XP - Home Edition - Pentium 4 HT. 3.06GHz 3GB Ram - laugh all you want, my other machine's an Atari 520 STFM... : P)

  Email Orkan [OO-XII]
Forger of Destiny
Chief Marshal
We Kick Arse

Joined: October 10, 2009
Posts: 826
Posted: 2013-12-21 06:22   
I have noticed, but not tested, that this bug happens on the first GCQL startup after a certain time. would appreciate people zero-ing on this certain time. cant zero in with an error less than 1 minute, but thatll probably be way more accurate than the devs would actually need.

it may be different for everyone, so multiple people finding this "special time" would be practical.

for me, its somewhere between 1600 - 0500 GMT (for reference, Hydra/Ogre server restart is always 1430 GMT)

edit: as far as i can figure, if youre logged in during that special time, the bug gets suspended.
[ This Message was edited by: Forger of Destiny on 2013-12-31 07:56 ]

Forging legends and lives outside till naught remains inside.

Null Pointer
Grand Admiral
Templar Knights

Joined: April 10, 2010
Posts: 148
Posted: 2013-12-23 19:53   
Just happened to me, logged in on the website, launched the game again, didn't work. Relogged and I was fine.


Joined: June 25, 2010
Posts: 787
From: Dres-Kona
Posted: 2013-12-28 18:21   
yeah seems random. But so far if you are NOT connected on the broswer when GCQL launches you aint connecting to MV

[ This Message was edited by: Soulless *CO* on 2013-12-28 18:37 ]
We are Back from the shadows.

  Email *FTL*Soulless
Powered by phpBB® Forum Software © phpBB Group
Page created in 0.013566 seconds.

Copyright © 2000 - 2019 Palestar Inc. All rights reserved worldwide.
Terms of use - DarkSpace is a Registered Trademark of PALESTAR