Welcome aboard Visitor...

Daily Screenshot

Server Costs Target


9% of target met.

Latest Topics

- Getting our Player Base back »
- What's with the new Metaverse? »
- Carrier default loadouts - ships w/interceptors only? »
- Holly Cow Its alive!! »
- 01001000 01100101 01101100 01101100 01101111 »
- the mi type ships cheat »
- First Person view is possible in DS! »
- Latency Issues »
- missing dll. »
- 1.741 »

Development Blog

- Roadmap »
- Hello strangers, it’s been a while... »
- State of DarkSpace Development »
- Potential planetary interdictor changes! »
- The Silent Cartographer »
- Cloaking update... »
- Tools for tips »
- Fleet levels and more! »
- Game Mechanics Question and Answer Thread »
- Under Construction »

Combat Kills

Combat kills in last 24 hours:
Kills chart
Killboard

Upcoming Events

- Weekly DarkSpace
06/22/19 +6.1 Days
- International Talk like a Pirate Day!
09/19/19 +94.4 Days
- Towel Day
05/25/20 +343.4 Days

Search

 

Anniversaries

No anniversaries today.

Facebook & Twitter

Why not follow us on Twitter or Facebook for more information and fan updates?

[FAQ
Forum Index » » Beta Testing Discussion » » "Lag" issues in v1.481...
 Author "Lag" issues in v1.481...
Gideon
Cadet

Joined: September 14, 2001
Posts: 4604
From: Oregon, USA
Posted: 2004-03-26 11:06   
We are collecting specific data reguarding the "lag" issues people are reporting having in v1.481.


We are looking for:


  • Status of the other objects in the area (missiles, fighters, players, planets, etc). Are they lagging too?

  • Status of your focus.

  • Frames per second and ping.

  • Are you suffering from massive hard drive activity before or during the lag?

  • Are other players "lagging" at the same time?

  • Was a wormhole created/closed in the area?

  • Did other player(s) enter/leave the area?

  • Are you still able to deal/recieve damage?

  • Are point defenses working correctly at the time?

  • Is your chat "lagging" or working perfectly smoothly at the time?

  • Anything else you can think of that might be pertanent.



We are looking for patterns, ways to cause the issue at will, and workarounds. Your aid is greatly appreciated.

[ This Message was edited by: Gideon on 2004-03-26 11:16 ]
_________________
...and lo, He looked upon His creation, and said, "Fo shizzle."

  Email Gideon
Axianda The Royal
Fleet Admiral
Terra Squadron

Joined: November 20, 2001
Posts: 4273
From: Axianda
Posted: 2004-03-26 11:32   

  • Status of the other objects in the area (missiles, fighters, players, planets, etc). Are they lagging too?

    4 planet cluster 1 was ours, other 3 nmy whit lvl3 D and F bases.
    They didnt appear to be lagged at all.


  • Status of your focus.

    normal not changed at all

  • Frames per second and ping.
    Frames: unknown Ping: 200-250ms

  • Are you suffering from massive hard drive activity before or during the lag?

    no activity here that is out of the ordinary

  • Are other players "lagging" at the same time?

    Yes we went in whit 4 transport to make a drop. all ships were jumping around the scene

  • Was a wormhole created/closed in the area?

    No WH at that time what so ever. they did however make use of the shipyard locaed in that cluster

  • Did other player(s) enter/leave the area?

    Several ships entered and left the area *dead or alive* some of the arriving ones came via SY

  • Are you still able to deal/recieve damage?

    Deal i dont know a transport cant realy harm anything but i did get my behind whooped by the EAD and planet defenses.

  • Are point defenses working correctly at the time?

    PD was working normally

  • Is your chat "lagging" or working perfectly smoothly at the time?

    AOK.

  • Anything else you can think of that might be pertanent.

    nothing comes to mind except that maybe the new combat indicator system for starmap could be interfering?




Hope this helps.

_________________

You can't outrun Death forever...
But you can make the bastard work for it.....

MSN: Axianda@hotmail.com

[ This Message was edited by: Axianda *XO* on 2004-03-26 11:32 ]
_________________

- Axi

Pope
Fleet Admiral

Joined: June 11, 2002
Posts: 2449
From: World of tomorrow
Posted: 2004-03-26 12:07   
I'm pretty much with Axianda on the described pattern, thanks Axi.

When my client actually thinks it can let me fire the weapons in question, they come out at different positions than my ship currently is visbile at (only projectile weapons of course), and go for the "real" enemy position from my "real" position.
I.E. If my client sends "fire torpedos" while everyone including me is warping around, the server appartently spawns the torps correctly and all is happy-tree-friends..


The Problems described occur totally beyond any determinability, there seems to be only a few things for sure:


- one or more Ships are in the area when they occur.

- Planetary defense, Combat or any kind of load does not cause them directly.

- "Impossible Maneuver" things like this happen frequently when the problem is active:
http://hydra.is-a-geek.net/ds/lag3/

- When all other ships leave the area the lag immediately ceases



-> HECK, Maybe the ship control vers are being mixed up?!



I dont know, i think we should make a controlled test in the MV with a few people, playing with stuff like line speeds. Every time i try to gather some data some bunch of kill frenzy ICC come and soon i have 10 Clients in the area some lagging some not, me lagging me not lagging...
_________________


Jaxom
Cadet

Joined: March 18, 2004
Posts: 2
Posted: 2004-03-26 13:18   
Status of the other objects in the area (missiles, fighters, players, planets, etc). Are they lagging too?

-yes, i am never the first to experience it, but eventually it gets me


Status of your focus.

-5000, as per autodetect


Frames per second and ping.

-my "normal" is 28-34fps, and it usually stays there, even when lagged. the only time it changes drastically is when i start "jumping" around. ping is almost always under 100ms, usually around 6oms.

Are you suffering from massive hard drive activity before or during the lag?

-no HDD activity at all

Are other players "lagging" at the same time?

-yes

Was a wormhole created/closed in the area?

-not to my knowledge

Did other player(s) enter/leave the area?

-yes, but it doesn't seem to make a difference(it happens just as bad when a few of us are just chilling in orbit around a planet)

Are you still able to deal/recieve damage?

-it would seem so, but i don't see my guns fire(no graphics). when i can't turn, i can't put my front guns on a target, so you could say my ability to deal damage is reduced. i still take it all though.


Are point defenses working correctly at the time?

-they appear to, but most of the time i don't see the graphics

Is your chat "lagging" or working perfectly smoothly at the time?

-it works most of the time

Anything else you can think of that might be pertanent.

-the lag seems to get progressively worse over time (as in, it wasn't as bad a week ago as was yesterday and today)


_________________


Seraph
Fleet Admiral

Joined: October 07, 2002
Posts: 446
From: Ohio
Posted: 2004-03-26 13:31   
Status of the other objects in the area (missiles, fighters, players, planets, etc). Are they lagging too?

For me, my ship will be moving but i can not turn when I try to, then all of a sudden it will break for a second and I will be aiming the other direction. The fighters seem to lag in my screen when I get that lag, then when it breaks it was like they weren't lagging at all.


Status of your focus.

Unchanged


Frames per second and ping.

Frames: unknown Ping: 180-220


Are you suffering from massive hard drive activity before or during the lag?

Doesn't seem like the hard drive is different either times.


Are other players "lagging" at the same time?

Yes all players in the MV lag same time I do, at least all around me and the rest of my faction.


Was a wormhole created/closed in the area?

Sometimes, I have noticed lag sometimes whrn a WH is opened near me,


Did other player(s) enter/leave the area?

Usually, due to dying and E-Jumping


Are you still able to deal/recieve damage?

Always, yet when fighting it always pauses, breaks, pauses, breaks......


Are point defenses working correctly at the time?

Yes even when I freeze I break and see my PD firing and hitting.


Is your chat "lagging" or working perfectly smoothly at the time?

Thats the funny thing, chat 90% of the time is unlaged, even when I'm froze.


Anything else you can think of that might be pertanent.

Maybe my system specs

Intel Pen 4 1.8ghz
Nvidia Geforce 4 440 MX 64mbs
1k of ram
120gb HD
56k connection

I hope this helps.

_________________


Doran
Chief Marshal
Galactic Navy


Joined: March 29, 2003
Posts: 4031
From: The Gideon Unit
Posted: 2004-03-26 13:41   

  • Status of the other objects in the area (missiles, fighters, players, planets, etc). Are they lagging too?
    inner core/nicea system, lots of fighters and missiles there, especially when ugto went after lambert,decca,terra1 yesterday

  • Status of your focus.
    either default (3k-something) or 1000. dont see much difference between the two

  • Frames per second and ping.
    >100ms in game, anywhere from 60-90. 11-12 hops to mirror-server.palestar.com, not more than 120ms
    20-30fps general, drops to 5 or less in pitched battles, also takes dives in nebulas (probably just my tnt2)


  • Are you suffering from massive hard drive activity before or during the lag?
    cant tell, havent been monitoring it, havent heard anything major tho

  • Are other players "lagging" at the same time?

  • Was a wormhole created/closed in the area?
    just to get a station in at the start of the assault

  • Did other player(s) enter/leave the area?
    had some comming and going on both icc and ugto yes. i myself was running inf into the cluster from the ORC cluster

  • Are you still able to deal/recieve damage?
    was in a modded light tranny for the lambert/decca/terra1 assault, so no damage dealing, was able to be damaged by planet def but did manage to sit in very close orbit of gettock for almost half a hour before it reached out and killed me

  • Are point defenses working correctly at the time?
    against missiles yes, still kinda hit or miss vs fighters

  • Is your chat "lagging" or working perfectly smoothly at the time?
    no big delays there. when it does get laggy or stop all together a disconnect usually follows

  • Anything else you can think of that might be pertanent.
    the alt+p display for latency, fps and all the rest. rather hard to read, bottom half of it flickers (lines of info being added and removed rapidly)
    make it a pain to track down fps and ping with the location of those value changeing so fast

    that just 2 frames i snapped for illustrative purposes, flickering is about twice as fast as that
    i for one dont know what most of that info is, and probably dont need to see most of it being just a client. maybe revise it and put ping,fps,bps etc on a small window on the F7 key...

    other thing of note, connection is 256kbps DSL. tend to have winamp runnin in backround streaming muisc in at 24 kbps, runs ping up 100-140ms under those cases,
    traffic-wise, >5kb/s incomming, maybe up to 2kb out



_________________

_________________
accepting donations to the 'Get Doran Subscribed' fund

[ This Message was edited by: Doran on 2004-03-26 13:43 ]
_________________


  ICQ status
Therax Anrak
1st Rear Admiral

Joined: February 07, 2004
Posts: 11
Posted: 2004-03-26 15:08   

  • Status of the other objects in the area (missiles, fighters, players, planets, etc). Are they lagging too?
    Lambert cluster. 4 planets total, all heavily fortified with lvl 3 defbases.

  • Status of your focus.
    Default, 5000 gu.

  • Frames per second and ping.
    Minimum of 20 fps, rising to 40 during lulls in activity. Ping is stable at 60 ms +/- 10 ms.

  • Are you suffering from massive hard drive activity before or during the lag?
    No HD activity at all.

  • Are other players "lagging" at the same time?
    Yes.

  • Was a wormhole created/closed in the area?
    No wormholes present.

  • Did other player(s) enter/leave the area?
    Players did arrive/depart the area, but it had no effect on lag that I noticed.

  • Are you still able to deal/recieve damage?
    Difficult to tell. The lag spikes are momentary, and it's hard to determine whether I am taking damage or whether my client is simply catching up with updates at the end of a lag spike.

  • Are point defenses working correctly at the time?
    My PD fires on some targets (fighters) within range, but not all.

  • Is your chat "lagging" or working perfectly smoothly at the time?
    See the damage question above. During extreme lag spikes, chat is lagged as well, but during the usual short lag spikes, chat is able to catch up and there's no noticable delay.

  • Anything else you can think of that might be pertanent.
    In the situation noted, triangles rendered ranges between 8000 and 28000, with no effect on lag. e.g. even with only 8000 triangles onscreen I was still getting substantial delay/lag in control response.

    An ongoing ping in the background to cygnus.palestar.com showed a few dropped packets coinciding with the worst of the lag, but well below 1% loss (9 lost in 5110 packets sent). However, with only a 1 second resolution on the ping, packets could very well be being dropped because the lag spikes are usually far shorter than this period. Is there any facility in the Darkspace client itself to detect or track dropped packets?

_________________


-=Arch=-
Cadet

Joined: July 10, 2002
Posts: 214
From: *CLASSIFIED*
Posted: 2004-03-26 18:17   

  • Time = 5:30 PM CST
  • Status of the other objects in the area (missiles, fighters, players, planets, etc). Are they lagging too?
  • One planet, just me. Little Deffenses

  • Status of your focus.
  • Default

  • Frames per second and ping.
  • 100-120 fps, <25ms

  • Are you suffering from massive hard drive activity before or during the lag?
  • Ive got enough RAM to run the entire game in it. zero Activity

  • Are other players "lagging" at the same time?
  • 2 others in another section of the system picking up inf reported laggy conditions

  • Was a wormhole created/closed in the area?
  • No

  • Did other player(s) enter/leave the area?
  • Not while I was there

  • Are you still able to deal/recieve damage?
  • Yes

  • Are point defenses working correctly at the time?
  • Yes

  • Is your chat "lagging" or working perfectly smoothly at the time?
  • Yes

  • Anything else you can think of that might be pertanent.
  • Experienced Jump Activation lag at the moment I tried to normal jump away from planet, Turn Delay Lag, and Weapon firing lag.





Ive added some pics that I shot that shows that Ive commanded my ship to steer out of harms way. Youll see that the turn indicator shows that I should be turning, but Im stuck in a turn in the opposite direction. Basically these show Im out of control and at the mercy of whatever position Im in when the controls freeze. The delay usually is less that 3-4 seconds.

At times I cannot fire weapons for a good 5 seconds even though the systems indication shows charged and ready.

Even with 1 person vrs. 1 planet I still was skipping at times about 30-50 gu in any direction. Once I come out of the skip I can be at times facing the completely diffeent direction.

Picture 1
Picture 2
Picture 3

AMD XP2600
1GB RAM
GeForce TI 4400 8X 128MB RAM
2 - 120GB WDD
Asus A7N8X nForce 2 Chipset
DX9.0b
Det 53.03 (beta)
XP Professional
Game set at 1023 x 768 x 32

_________________







[ This Message was edited by: -=Arch=- on 2004-03-26 18:29 ]
_________________


  Goto the website of -=Arch=-   ICQ status
Mr tinkles anti wibblinator
Cadet

Joined: October 13, 2002
Posts: 435
Posted: 2004-03-26 19:23   

[*]Status of the other objects in the area (missiles, fighters, players, planets, etc). Are they lagging too?
trying to cap a planet in nicea ic1 to be correct
[*]Status of your focus.
a torp crusier

[*]Frames per second and ping.
ping was 18MS and FPS was in the high 60s
[*]Are you suffering from massive hard drive activity before or during the lag?
no

[*]Are other players "lagging" at the same time?
most of the time YES

[*]Was a wormhole created/closed in the area?
NO

[*]Did other player(s) enter/leave the area?
no

[*]Are you still able to deal/recieve damage?
very YES

[*]Are point defenses working correctly at the time?
DEFFINNNATEly yes

[*]Is your chat "lagging" or working perfectly smoothly at the time?
doesnt lag at all
[*]Anything else you can think of that might be pertanent.

my controls are acting like I have to send the command and wait like a minute actually a couple of seconds for them to work

_________________
Just say no to intel!!!!

  Goto the website of Mr tinkles anti wibblinator
Diabo|ik
Grand Admiral

Joined: August 16, 2002
Posts: 327
From: Quebec, Canada
Posted: 2004-03-26 20:56   
-Status of the other objects in the area (missiles, fighters, players, planets, etc). Are they lagging too?

A few planets with lit def bases coverage. ( mostly missiles )


-Status of your focus.

Default for 56k modem
Default for DSL

Note: Used another computer with the other connection in the same session ( played on the modem first then switched to DSL, 30 minutes tests for both ) and both suffered from the issues mentioned here.

-Frames per second and ping.

monitor refresh rate, sometimes drop to 50 in BAD situations fps ( both video cards )
150-200ms with modem ( same as with the old patch btw, for DSL too )
50-75ms with DSL

Are you suffering from massive hard drive activity before or during the lag?

512 megs o ram, no swapping at all


-Are other players "lagging" at the same time?

Complaints about lag showing up in the chat, so I'd say yes.


-Was a wormhole created/closed in the area?

Negative


-Did other player(s) enter/leave the area?

Rarely


-Are you still able to deal/recieve damage?

Yes for torps and guns, no for beams ( albeit the torps and guns DO damage the others, they frequently just are invisible and can't be detted and it makes it very hard to pick a good trajectory for the ongoing battle ( since you don't know where the hell they're going )


-Are point defenses working correctly at the time?

Was turned off most of the time, but when I activated it it did work from time to time ( sometimes missiles would just fly in my ELFs arcs and they wouldnt do squat )


-Is your chat "lagging" or working perfectly smoothly at the time?

Sometimes


-Anything else you can think of that might be pertanent.

Jump lag, turning lag, weapons firing lag ( mash spacebar, nothing happens then poof the torps and damage appears... Can't det torps, can't see the other players weapons, so can't evade )

And the oh so classic "heck I'm jumping all over the place lag". ( especially when you give fast commands to maneuver one side then the other alternating right/left )

And I'm having a hard time controlling my speed too.

XP2100+/XP1700+
A7V333-X mobo/same
512 megs/same
Geforce4Ti4200-8x/Ati Radeon9800PRO, both 128 megs
Latest Directx/same
52.16 revision Nivida drivers / latest Catalysts as of last week
ESS ES56T-PI Data Fax Modem/ Some DLink Ethernet card connected directly to the DSL modem ( removed the router and replaced it, same results )

_________________

We're legions, we're under your bed, under your couch, we're smiling at you while you sleep, we're everywhere, we're Evil...

[ This Message was edited by: Diabo|ik on 2004-03-26 20:58 ]
_________________
Mostly Retired.

Koda
Marshal
Fatal Squadron


Joined: August 29, 2002
Posts: 1384
Posted: 2004-03-27 02:14   

  • Status of the other objects in the area (missiles, fighters, players, planets, etc). Are they lagging too?

    I havent noticed any lad of any def besides PD not working on Fighters. but i understand that is becuse the fighter is already dead, and hasnt been updated to my com.

  • Status of your focus.

    Default settings

  • Frames per second and ping.

    20/ with def going off and ship vs ship combat and arround 120+ all by my lonesome

  • Are you suffering from massive hard drive activity before or during the lag? Im using a 3 yr old HP with upgrades in ram & and a better graphics card. So i normaly Reset my com b4 i go into battle to be at my best. When i play DS, i only have a handfull of programs running, IE fire wall, anti-virus programs running, but no other windows running. I use RR for my service provider, so i dont have any popups.

  • Are other players "lagging" at the same time?

    At times yes and and other times no, im sorry i cant be more specific. Ive been with a handfull of people and we all lagged, and at other times ive been in battles of 15+ that went smooth. All i can say is its the damdest thing.

  • Was a wormhole created/closed in the area?

    Yes, i was in a small bomber group (3ppl) and 2 Kluth stations WHed in using the same WH. we were about 10k gu away in the BD sys at Nhezhack and they were recaping Andys. Instantly after that my main priority was to try to not smash into the planet. I narrowly missed the planet and being eating alive by the planet def.. (7def bases .. 4-5 were Db3's)

  • Did other player(s) enter/leave the area?

    yes and no, depending on different incidents

  • Are you still able to deal/recieve damage?

    When bombing yes i still recieve damage, and deal it to the planets in the form of Mirvs

  • Are point defenses working correctly at the time?

    When bombing, yes for Planets and Ships. for some reason i can't turn.

  • Is your chat "lagging" or working perfectly smoothly at the time?

    my Chat will lag

  • Anything else you can think of that might be pertanent.

    Sometimes ill see ghost ships, sometimes ill see people when i go through the gate and ill select them..(friend or foe).. and a few seconds or longer later they maybe hundreds of thousands of Gu away.. and sometimes there will be lines of people all by the Jumpgate that arent really there. And there are even times ill see Ghost ships that will have No Diamond to select at all.. you can shoot them you can manually hit them with lasers and torps .. the longest time ive ever seen one of these kinds of ghosts was about 5 min.



Edit: and ill also get that spaztic ALT+P thing like Doran is showing... which makes trying to get you a real # for these messages a pain in the back side.

_________________




The World Is Not Enough



[ This Message was edited by: Vicious on 2004-03-27 02:16 ]
_________________






Rocki
Grand Admiral

Joined: August 13, 2002
Posts: 1028
Posted: 2004-03-27 13:23   

  • Status of the other objects in the area (missiles, fighters, players, planets, etc). Are they lagging too?

    other players are

  • Status of your focus.

    autodetect so i suspect about 1500-2000

  • Frames per second and ping.

    as usual, nothing abormal

  • Are you suffering from massive hard drive activity before or during the lag?

    not in particular

  • Are other players "lagging" at the same time?

    massively

  • Was a wormhole created/closed in the area?

    nope

  • Did other player(s) enter/leave the area?

    nope

  • Are you still able to deal/recieve damage?

    couldnt try, was at a friendly planet

  • Are point defenses working correctly at the time?

    see above

  • Is your chat "lagging" or working perfectly smoothly at the time?

    working ok

  • Anything else you can think of that might be pertanent.

    it started with a little control lag, then later everything just froze. i was immobile, but tops was headed towards ahwa at full speed and crashed into it when he was already in the lobby for a few minutes

_________________


Powered by phpBB® Forum Software © phpBB Group
Page created in 0.043832 seconds.


Copyright © 2000 - 2019 Palestar Inc. All rights reserved worldwide.
Terms of use - DarkSpace is a Registered Trademark of PALESTAR